We've identified the cause of the issue and have implemented a fix. We are monitoring the system to ensure that the system continues to perform as expected.
Posted Jun 03, 2026 - 19:55 EDT
Update
We are continuing to investigate the degraded performance in Workzone. We're working diligently to find a solution as quickly as possible.
Posted Jun 03, 2026 - 17:27 EDT
Investigating
Workzone is performing slowly. We are investigating the issue in hopes of having the system running optimally as soon as possible.
Posted Jun 03, 2026 - 09:30 EDT
This incident affected: Website, Workzone Mobile, and Workzone API.